Not able to add an Android Device

#1

Hi All,

Using this forum for first time, but I believe its quiet responsive forum.

I am using Mac desktop and is doing an automation for mobile devices. I have installed Appium Desktop and Appium Studio. I tried adding an Android device in appium studio but the popup just goes in a flash. But the pop up to add devices comes up for iOS.

The appium studio version is 12.7.5 and its a community edition.

Any further input required please feel free to let know

0 Likes

#2

Please try to attach screen shot or please provide the error from the Error log.

To get the Error log , From menu click Open Logs folder , and paste the error from the file Appium Studio*.log

0 Likes

#3

Thanks Kishore for your prompt response. The log file is empty.

0 Likes

#4

Close your appium studio and then check if its not empty and if so paste the log

Also have you tried provisioning the IOS profile ?
See - https://docs.experitest.com/display/TC/AS+-+Connecting+an+iOS+Device

0 Likes

#5

Navigate to log file from Appium Studio
Help–>>Open Log folder.
Open the latest log file and modify the below command as per the path you find in your log file

sudo chmod +x /Applications/AppiumStudio/bin/adb/adb

0 Likes