Unable to automate Safari on iPhone


I’m trying to automate Safari on my iPhone 6S (iOS 13.4).
But when I open it with AppiumStudio I’ve got an error :


And when I try to execute my java code :

org.openqa.selenium.SessionNotCreatedException: Unable to create a new remote session. Please check the server log for more details. Original error: session not created (An unknown server-side error occurred. status=‘false’. Failed to complete internal method: ‘launch args: [com.apple.mobilesafari, false, true]’, details: Failed to launch activity / URL. Error Domain=XCTDaemonErrorDomain Code=39 “Deprecated API. Call _XCT_fetchAttributes:forElement:reply: instead.” UserInfo={NSLocalizedDescription=Deprecated API. Call
_XCT_fetchAttributes:forElement:reply: instead.}

The device display is lost frequently, and finally I have this error.
This is the first time I’ve got this, and the first time I try to automate Safari so I really need some help.



Which version of of Appium Studio you are using and which operating system ?
Also did you upload the Safari application in Android studio ? If where did you get the application ?

I use Appium Studio 20.2.6560 on Windows 10.
No I’m trying to use the already installed Safari browser. I’m not uploading it.

I am also facing the same issue.

Appium version - 20.2.6560
Device : iPhone XR, OS 13.4
Windows machine


Please help

This is the exception I am getting while executing

Did you find any solution for this?

I’ve tried with version 20.1.6447 and doesn’t have this error but another one (maybe linked to my device) : “dev mode utility failed”

I received the same error on version 20.1.6447. - “dev mode utility failed”

Then I installed 20.2.6560 and got the same error as you did: “XCTDaemonErrorDomain Code=39 …”
When I closed the error and opened the device again, it worked. So I tried executing tests from IntelliJ. The app launched, a loop of opening and closing Cyder started and eventually the device disconnected, displaying the error “Display unavailable”.


Check whether 20.3 version resolve this issue. Let me know

This is a link for SeeTest Automation Tool; not Appium Studio.

There is appium studio enterprise version as well, right?

Tested with SeeTest Automation 20.3, no error with my iPhone device. But in facts, SeeTests Automation configuration is not the same than Appium Studio. I can’t use it with Intellij :

Unable to create a new remote session. Please check the server log for more details. Original error: Unable to parse remote response: <?xml version="1.0" encoding="UTF-8"?>faultCode0faultStringFailed to parse XML-RPC request: Content is not allowed in prolog.

I am using Community Edition, so I will probably wait for a new release.

Also using Community Edition.

I’ve got the same error on version 20.1.6447, maybe linked to iOS version ?

Maybe it is an incompatibility between the Appium Studio version and the iOS version.

I am also seeing this error after updating an iPhone X from iOS 13.1 to 13.4.1
Has anyone figured out a workaround?

Same as mentioned in thread Appium Studio not working for Ipad OS 13.4

Anyone got any solution for this? or any alternative?


I think currently there is not work around as there is no support for 13.4 in Appium Studio 20.2. Please wait for 20.3 to be uploaded in Appium Studio community version website.

Thank you for your response!