Possible solution to the Provisioning Profile issue

In recent times I’ve seen and experienced a mass amount of provisioning profile issues when connecting devices to Appium studio.
This has been particularly happening after logging in to the developer account and registering a certificate.
My team and I, after a few days of struggle managed to find that the core issue is with the certificates that are being registered when logging the account into Appium-studio to solve this mass issue,

  1. Head to the ios developer account management.
  2. Create a new “IOS development” certificate and give it access to all permissions.
  3. Make sure that the accounts that are mentioned in the developer account are selected as part of the certificate.
    This is what worked for us, keep in mind it may not work for you, please have patience with the issue and standby for an official solution if it is being worked on.
    A note for the team, it could be originating from the cyder app, the eureka moment for us happened after we found that the app requires its own permissions.