Not able to click on a field

Hi All,

I am not able to click on a field that would open keypad in an iOS application…
But I can see the red dot/highlight around the field…
Please help…

Hello Shashank,

Can you paste the image ?

  • Did you find element on the based on XPATH ?
  • What failure you get when you attempt click ? What are the properties of the element you are attempting to click.

Hi Kishore,

Yes I did find the element using Xpath.
I have tried :
1)Find Element and Click

All the other actions(Ex:Swipe,etc) are working fine


  • what error are you getting?
  • Can you paste the properties of this element which Object spy provides you ?

Hi Kishore,

There is no error message…
Also attached the screenshots


Thanks Shashank. … and you are loading this application in device or simulator ?

hello kishore,

I am loading this appliation on a device

Okay . Interesting.
Since this is generally seen with Simulators. I think its either a setting in you device or the app setting.

So when you are manually loading your application without Appium Studio this keyboard is available?

Hi Kishore

This was an issue with the orientation on the iPad…
It had to be changed to landscape mode(Device Action: Landscape)…

Thank you for your quick support :slight_smile:

Excellent . Glad this problem got solved.

We have observed that keyboards are not some time available in Simulators and that setting is available in Simulators itself.