License Error in Appium Studio Enterprise

The cloud license needs to be refreshed after approximately 7 to 10 mins of script execution and on refresh the license lasts for another 5 mins before the license terminates. The user has to reopen Appium Studio.

This is more of networking issue. Please check with your network team first.

If it was a common problem then other users also would face the same problem

Hi Kishore, we have tried on different networks within our office and also on our home network, but we are getting the same issue.

Also, when we try to connect to any of the cloud devices from Appium Studio we get a error saying “Bad credentials, invalid username or password” when we select login using credentials, while connecting using Access Key it says unable to connect to server, but the same credentials work fine while connecting to “” using a browser

Appium Studio community version cannot connect to Seetest Public Cloud.

You will have to use Appium Studio Enterprise version to configure the public cloud via below Menu option of AS Enterprise

The above screenshot is taken from the Appium Studio Enterprise version.

The place you get “we get an error saying “Bad credentials, invalid username or password”” is not a place to connect the creds of the cloud. It is authentication that checks against registration elsewhere and not in the public cloud.

I am using Appium Studio Enterprise edition and also giving a valid access key, but still i get the same error.

Please mail me directly when since this issue is licencing issue for Enterprise edition. I think I have already mailed you with me being in CC . Please reply in that mail.