Failed to Registering Free Provisioning OS developer account with Appium Studio

While logging with Apple developer account in Appium studio, I’m getting below error.

I’m able to login to the account, after successful login Appium Studio listing team (Free provisioning Program).
When I click on register button I’m getting below error. (Image)

Any one faced same issue?

Hello,

  • Was it working before ?
  • Which Appium Studio version ?
  • Are you using paid developer account ? If Free how many days it has bee that you had created ?

No not faced this problem.

You get this problem I think because you are using Free Provisioning Program , this check must have been new by Apple. Please try paid account.

Hi Kishore,

Its working just 15 days back.
Appium Studio Version: 12.10.6022
I’m using free developer account (its created more than 2 years back)

But is it mandatory to use Paid account,is there any alternative for this?

This is an error from Apple site, it is possible that they have recently added this check
I have a paid developer account which works fine but the free account does not work well.

This error is from backend when Appium Studio connects Apple with your credentials. Please check with your developer account (paid ) and let us know

Appium Studio always recommended paid account as free account had its own limitation even before.

If Apple has added something recently, even some other user complained , Appium Studio cannot do much about it
See the log below when we use Free account, the log indeed shows that its from Apple;s classes (not related to experitest related classes which is generally com.experitest.)

Server says: Please update to Xcode 7.3 or later to continue developing with your Apple ID. (3018).
at xign.client.entity.AppleServiceResponse.putRawResponse(AppleServiceResponse.java:49)
at xign.client.AppleDeveloperPortalClient.extractAppleServiceResponse(AppleDeveloperPortalClient.java:538)
at xign.client.AppleDeveloperPortalClient.sendRequest(AppleDeveloperPortalClient.java:448)
at xign.client.AppleDeveloperPortalClient.sendRequest(AppleDeveloperPortalClient.java:336)
at xign.client.entity.certificate.XCCertificateProvider.submitDevelopmentCSR(XCCertificateProvider.java:72)
at xign.client.entity.certificate.XCCertificateProvider.submitDevelopmentCSR(XCCertificateProvider.java:62)
at com.experitest.device.ios.profile.devportal.DevPortalController.submitDevelopmentCSR(DevPortalController.java:260)

Thanks for the Info, I’ll try using paid version

I think its best to wait for an update by me.

Hi,

I tried login with multiple paid accounts but i’m getting below error. Please help me in resolving the issue ASAP.

Hello,

I have mentioned to wait to try to get new developer account in last message.
“I think its best to wait for an update by me.”

BTW it could be because you are using normal password rather than App-Specific password.
Here is the way - https://support.apple.com/en-in/HT204397
Let me know whats it the result.

I tried with multiple new developer accounts.

I’ll check about the app specific password.

Hi Kishore,

did you find anything?

As mentioned before, we will update when the problem is fixed.

Hi kishore,

i am facing the above mentioned issue .any update regarding this ???

We are working on the issue, when the problem is solved we will update this thread