"Failed to connect to XCAutomation" error with iOS version 17 and Appium studio version 23.9.9184

i am getting error “Failed to connect to XCAutomation” while trying to open iPhone with iOS version 17 and Appium studio version 23.9.9184
Developer mode is on my iPhone

Facing the same error let me know if you find any solution, looks like Appium Studio community support is of no use now. no one replies here now

For me also facing the same issue recently, I have updated the Appium studio version to (24.2.9288) but still the issue exists. Suppose if you find any alternate solution kindly share to me also.

I am currently using Seetest 24.2 and it’s also developed by digital ai and it doens’t support iOS version => 17.X so I believe Appium also have same limitations. And there is no update like in future it’ll support or not. It’s really very frustrating.
As of now using a cloud device is only solution. Any physical device with iOS 17.X is not supported by digital ai.

Hi Friend, Even i am also getting this compatible issue Appium Studio not working with ios version >=17. Please let me know if u find any work around for this. Thanks!!

Hi community Users, seems many people became inactive on this appium studio community. Please Let me know if u guys moved from appium studio or still an option for mobile testing please.
Kindly excuse me since i am tagging everyone just with the hope i may get help from someone who solved this or any work around.

@RajasekaranT @hammad @tabish @appiumdiscuss @Appium_AA @diget @Arundoss @rahee @Mor.Experitestb @mateoaqx

Just adding the community folks to above thread.

@Shiba @uzi @chinni.sai @bindu @Bin @ben7 @Feng @FeliciaWieser @foxi @finn

@Khristo @kavithaadapala1 @koltonbrownqa @Kaelus @system @Suraj @hammad @evanarendra @gugapiyal @Gina

I personally have no idea, i also currently have the issue, I’ve simply been avoiding devices with IOS17, it might be because apple changed a lot in ios 17 with the developer options.
Ive tried enabling pretty much anything that has to do with automation in the developer section and I’ve gotten nothing, I’ve also updated Appium to 2.0 and still nothing.
The current suggestion from management is to find a different option other than Appium Studio which I haven’t done yet but will look further into, I prefer to find a solution for this before moving on to a different tool.
Ive also struggled all round with using Appium Studio as it feels close to impossible to reach experitest.
If anyone does indeed have a solution please mention it!

1 Like

I am also searching for a solution for this compatibility issue. I am requesting the Appium Studio community edition to respond to this issue because many users are awaiting the dependent Appium Studio version. Suppose if anyone finds the alternate solution, just post it. It may help many users.

Continuing the discussion from "Failed to connect to XCAutomation" error with iOS version 17 and Appium studio version 23.9.9184:

I will note, should there be a paid more advanced version I would be more than happy to pay a reasonable amount for it.

It seems to be working now and i’m pretty happy about it, NOTE: Remove your bundle id from your capabilities, run without one, otherwise the app wont launch and give an error that its not installed.

One question, if we remove the bundle id how session will understand which app to launch? correct me if my understanding is wrong.

@chinni.sai Hi Sai, is is possible to take a look on this. I read somewhere you are from experitest team.


it gets it from appiumstudio itself, whenever appiumstudio has a file being downloaded to it it generates its own code, you can see it by clicking on code next to the log button.
this has been my experience personally.

HI all
Is this issue fixed Currently I’m facing the issue

Hi Tabish,

You can try below steps -

-Make sure you have the latest version of Xcode.

  • Ensure Developer Mode is enabled on your iPhone.

-Restart both your iPhone and your computer.

-Check the USB cable and port for any issues.

-Verify that your iPhone trusts your computer.

-Ensure you have the latest version of Appium Studio that supports iOS 17.

Check the Appium Studio logs for more detailed error information.

Hope it helps !

Thank you

Hello @nolanmaris

i think the step you mentioned is for Mac book .

can you let us know if same is possible for windows machine?