Clickable elements are not click in appium Studio

#1

When executing IOS automation scripts via appium Studio, it’s correctly locating the clickable elements by xpath. But, did not perform the click action. When i executing my scripts, it shows correctly taking that exact xpath, but did not perform the click action. I am experiencing this issue only IOS, not in Android. I am using Appium studi 12_1_80 version and i tried out 12_2_4878. I experienced same issue in both.Earlier it works fine.

Example- Enter user name and password in login page Click on Sign In button But, Element is correctly located sign in button. But, it did not perform click action. Earlier same script is worked fine.( yesterday)

Please tell a solution for this issue

0 Likes

#2

Get the log from the log folder after you do the test. The log should be Appium*.log

Make sure have the log with only your test.

0 Likes

#3

Hi Kishore,
I have checked logs. But, it’s shows an error that after click on the sign in button, i verify the logo in home page. It didn’t navigate to homepage due to that issue. Showing as " That xpath didn’t perform" due to that page is not navigated. Do you have any idea?

0 Likes

#4

Please help me to solve this issue.
Elements are correctly locating . But, Click action didn’t perform .

0 Likes

#5

Sorry, I am not sure the reason why you did not receive my reply mail you.

Please send me the logs, to troubleshoot further.

Thanks

0 Likes