Cannot Register Apple ID

Hi!

I have installed Appium Studio for Windows two weeks ago. All good until today, when it was required to re-enter my Apple ID. After providing the correct credentials, I get this error:

Bad response from server.
200: OK
Server says: Please update to Xcode 7.3 or later to continue developing with your Apple ID

Appium Studio = Version 12.10.6022

Please try to check the your Apple Id account, it does not look to be an Appium Studio for problem.
Looks like this error which is caused when Appium Studio tries to contact Apple site for Apple Id check.

I will try that. Thank you

Can be this problem connected with latest Apple server update?

My Cyder app went out of date, how can i update him?

Ty for reply <3

I advice you to do the following

  • Remove the Provisioning for iOS what you have done in current Appium Studio installation
  • Uninstall Appium Studio (do all cleanup , in AppData/AppiumStudio and Program Files/Appium Studion), Also check there is no Cyder in you Device if there is uninstall it
  • Restart your machine & Device
  • Download the Latest Appium Studio
  • Install the Appium Studio after reboot
  • Provision iOS profile again …

Hi kishore,

I have tried this method, but not working.
The situation is still the same as previous comment when register iOS developer account.
It will effect the Cyder app update. Please help for a look, thank you.

Sorry, I am asking you again.
I request you to redo steps but with the order of steps which I have mentioned below

  • Remove the Provisioning for iOS what you have done in current Appium Studio installation
  • Remove the Cyder
    *Go to Settings > General > Device Management and remove any Experitest certificate you found here
  • Disconnect your device
  • Uninstall Appium Studio (do all cleanup, in AppData/AppiumStudio and Program Files/Appium Studio)
  • Restart your device and machine
  • Download the Latest Appium Studio
  • Install the Appium Studio after reboot
  • Provision iOS profile again …

Let me I know how it goes, Idea is to not update but make sure that Cyder or any reference of Appium Studio is not there in the machine or device

I hope it works as it has worked before …

Hello Alexandru,

Are you using Free Provisioning account ? I am saying this because one of the reason of this problem is when we use Free account , Apple have made a check and responds with this error.

Please let me know with your answer.

Yes, it is a Free one

Also, i found this reddit post related to the same error: https://www.reddit.com/r/jailbreak/comments/dslnaw/help_help_with_cydia_impactor/?sort=new

Maybe it helps…

Alexandru, I have replicated this problem with Free Account.

See - Failed to Registering Free Provisioning OS developer account with Appium Studio

The Paid developer account works fine as of now.

If Anything is we get info will update in this thread - Failed to Registering Free Provisioning OS developer account with Appium Studio

I see, thank you for your response. So, basically, i need to acquire a paid account

I found out because I have both developer paid and free account.

But I think its best to wait for an update by me

Hi kishore,

Thanks for your reply. I found the root cause is the same as this thread - Failed to Registering Free Provisioning OS developer account with Appium Studio and will wait for your update, thanks again.