Unable to connect to iphone

Error message says Failed to get list teams. Could not login

Can you login to AppStore using this Apple ID?
Is it an Apple ID that you are using or a developer account?

Please also check your proxy configuration.

@Navot yes I use this credentials to login to my apple account.

@guy Im not using any proxy to connect to the Internet.

@Raghu - Can you please upload the stacktrace from the log file located at - C:\Users\DELL\AppData\Roaming\appiumStudio
The log file name will look something like this - Appium Studio-2017-03-10-01-36-13.log

If you don’t see the file please use collectSupportData - Help->CollectSupportData and send us the zip

Hi All ,

I am also facing the above issue, Could you please assit.

I am trying to connect Iphone 5s in windows machine

Try to create a new developer certificate inside the AppleDeveloper site and try again with your credentials.

If it’s possible, delete older certificates before creating the new one.

Check this post… Cannot Register Apple Developer Account

  1. Go to https://appleid.apple.com/#!&page=signin
  2. Log_in with your apple id, go to security, and Generate app-specific password
  3. Use the password as our apple id password to log in to AppiumStudio.

Credits to @Harsha

1 Like

After entering correct credentials via “Register IOS developer account”. I am unble to connect my i phone in appium studio. Ok Button became invisible to add that device in appium studio.

Kindly do needful for same. I have my developer account ceredentials and already registered with appium studio.

We are using Charles to connect our client VPN. So is it any problem?
We have paid developer account and through it we can resister our device profile for Iphone as well. Through this credentials we are able to login to Apple developer account.

Thanks in advance. Please help me.

Hi, just hapened to me after reinstalling AppiumStudio. Try this:

  • In the window you attached, click over the Apple+ icon at botton left
  • Select the first option (can’t remember what says but it’s similar to add the userid) and click Next
  • Write your Apple Developer Account username & Password, also check the Keep Me Logged box, then press Login
  • Select your team and click Register
  • A message saying Enabling developer mode blah blah blah appears, click OK

Now the OK button is enabled and you can add your iOS device

No, Not working On my MAC book Pro machine.

1 Like

Were you able to solve the problem?
I am also having MAC Book Pro and having the same issue. OK button is not enabled

I solved the issue.
From the Appium Studio Logs:
2018-10-01 18:56:03,494 [AWT-EventQueue-0] (ios.profile.b) ERROR Apple Worldwide Developer Relations Certification Authority doesn’t exist
2018-10-01 18:56:03,494 [AWT-EventQueue-0] (imagestudio.cy) WARN com.experitest.device.ios.profile.NoWorldWideCertificateException: Apple Worldwide Developer Relations Certification Authority doesn’t exist

There was issue with the Apple Worldwide Developer Relations Certification Authority Intermediate Certificate and iOS.
I have installed the same via the below link and its working like charm now…


I have the same problem.
I have iOS developer account. I can see it in https://developer.apple.com/account/
I have installed this apple certificate: https://developer.apple.com/certificationauthority/AppleWWDRCA.cer
I have tried two factor authencation with generation app-specific password and trying that.
I have tried removing two factor authentication.

With collect support data a have got this error log:

Product name: AppiumStudio
Appdir path: C:\Users\JE24528\AppData\Roaming\appiumstudio
Starting the internal [HTTP/1.1] server on port 4723
2019-05-14 08:54:11,535 [SwingWorker-pool-10-thread-1] (ios.a.M) ERROR Failed to get list teams
xign.client.execption.LoginException: Could not login

at xign.client.AppleDeveloperPortalClient.login(AppleDeveloperPortalClient.java:261)
at xign.client.AppleDeveloperPortalClient.create(AppleDeveloperPortalClient.java:196)
at com.experitest.device.ios.profile.devportal.b.f(MyApplication:67)
at imagestudio.panels.ios.a.X.YF(MyApplication:729)
at imagestudio.panels.ios.a.X.YD(MyApplication:707)
at imagestudio.panels.ios.a.X.operationPerformed(MyApplication:480)
at com.experitest.lcmt.b.a.h.E(MyApplication:27)
at imagestudio.panels.ios.a.W.doInBackground(MyApplication:323)
at javax.swing.SwingWorker$1.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at javax.swing.SwingWorker.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: javax.ws.rs.ProcessingException: Already connected
at org.glassfish.jersey.client.ClientRuntime.invoke(ClientRuntime.java:264)
at org.glassfish.jersey.client.JerseyInvocation$1.call(JerseyInvocation.java:684)
at org.glassfish.jersey.client.JerseyInvocation$1.call(JerseyInvocation.java:681)
at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
at org.glassfish.jersey.internal.Errors.process(Errors.java:228)
at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:444)
at org.glassfish.jersey.client.JerseyInvocation.invoke(JerseyInvocation.java:681)
at org.glassfish.jersey.client.JerseyInvocation$Builder.method(JerseyInvocation.java:437)
at xign.client.AppleDeveloperPortalClient.sendRequest(AppleDeveloperPortalClient.java:370)
at xign.client.AppleDeveloperPortalClient.sendRequest(AppleDeveloperPortalClient.java:281)
at xign.client.AppleDeveloperPortalClient.login(AppleDeveloperPortalClient.java:247)
… 13 more
Caused by: java.lang.IllegalStateException: Already connected
at sun.net.www.protocol.http.HttpURLConnection.setRequestProperty(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.setRequestProperty(Unknown Source)
at org.glassfish.jersey.client.internal.HttpUrlConnector.setOutboundHeaders(HttpUrlConnector.java:421)
at org.glassfish.jersey.client.internal.HttpUrlConnector.access$100(HttpUrlConnector.java:96)
at org.glassfish.jersey.client.internal.HttpUrlConnector$4.getOutputStream(HttpUrlConnector.java:384)
at org.glassfish.jersey.message.internal.CommittingOutputStream.commitStream(CommittingOutputStream.java:200)
at org.glassfish.jersey.message.internal.CommittingOutputStream.commitStream(CommittingOutputStream.java:194)
at org.glassfish.jersey.message.internal.CommittingOutputStream.commit(CommittingOutputStream.java:262)
at org.glassfish.jersey.message.internal.OutboundMessageContext.commitStream(OutboundMessageContext.java:816)
at org.glassfish.jersey.client.ClientRequest.writeEntity(ClientRequest.java:545)
at org.glassfish.jersey.client.internal.HttpUrlConnector._apply(HttpUrlConnector.java:388)
at org.glassfish.jersey.client.internal.HttpUrlConnector.apply(HttpUrlConnector.java:285)
at org.glassfish.jersey.client.ClientRuntime.invoke(ClientRuntime.java:255)
… 24 more

Ask for further details if needed.

Peter H.

I had the same problem, it was because I had 2-Factor Authentication on. You need to create “app password” as described here: https://support.apple.com/en-us/HT204397 and login with it. And It worked without disabling 2FA.

Hi ,
I am also facing the Same issue .

  1. I have valid iOS developer account
  2. I have generated the App Specific password

When trying to register , I am getting error as "Failed to get Teams , Could not Login "

How can I resolve this issue ?

Sorry guys,
I am facing this same “Failed to get Teams , Could not Login” issue with the latest Community version 22.1.8625 installation.
I have verified that the Apple ID + App Specific password work on another Windows 10 PC with Appium Studio.

Reading the Appium Studio log:
2022-02-22 17:10:08,257 [AWT-EventQueue-0] (imagestudio.IosInstrumentationAccountAction) INFO Action: iOS Provision Profile Management…
2022-02-22 17:10:09,986 [AWT-EventQueue-0] (panels.ios.ProfileImportDialog$5) DEBUG Action: RegisterDevAccount
2022-02-22 17:10:10,044 [AWT-EventQueue-0] (ios.instrumentation.RegisterDevAccountPanel) DEBUG Created RegisterDevAccountPanel:login state
2022-02-22 17:10:22,984 [SwingWorker-pool-12-thread-10] (ios.instrumentation.RegisterDevAccountPanel) DEBUG Getting listTeams for appleId pqe.server.admin@qti.qualcomm.com
2022-02-22 17:10:23,386 [SwingWorker-pool-12-thread-10] (ios.instrumentation.RegisterDevAccountPanel) ERROR Failed to get list teams
xign.client.execption.LoginException: Could not login

	at xign.client.AppleDeveloperPortalClient.login(AppleDeveloperPortalClient.java:326)
	at xign.client.AppleDeveloperPortalClient.create(AppleDeveloperPortalClient.java:258)
	at profile.devportal.DeveloperPortal.listTeams(DeveloperPortal.java:63)
	at imagestudio.panels.ios.instrumentation.RegisterDevAccountPanel$RegisterAccountController.handleLogin(RegisterDevAccountPanel.java:731)
	at imagestudio.panels.ios.instrumentation.RegisterDevAccountPanel$RegisterAccountController.loginActionPerformed(RegisterDevAccountPanel.java:709)
	at imagestudio.panels.ios.instrumentation.RegisterDevAccountPanel$RegisterAccountController.operationPerformed(RegisterDevAccountPanel.java:482)
	at com.experitest.lcmt.form.controller.FormOperation.operationPerformed(FormOperation.java:27)
	at imagestudio.panels.ios.instrumentation.RegisterDevAccountPanel$LoginPanel$1$1.doInBackground(RegisterDevAccountPanel.java:325)
	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at javax.swing.SwingWorker.run(SwingWorker.java:334)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
**Caused by: javax.ws.rs.ProcessingException: javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target**
	at org.glassfish.jersey.client.internal.HttpUrlConnector.apply(HttpUrlConnector.java:284)
	at org.glassfish.jersey.client.ClientRuntime.invoke(ClientRuntime.java:278)

Seem it is certification path issue. I have tried to install this apple certificate: https://developer.apple.com/certificationauthority/AppleWWDRCA.cer, and issue still there.

Any other suggestions please?
Many thanks.

The issue I faced seems related to the specific Windows machine with v22.1.8625. I manage to reinstall an older version (20.4.6801) and I manage to sign-in and register. Therefore, rule out https://developer.apple.com/certificationauthority/AppleWWDRCA.cer.
Will post my findings later.

Sign in and register with v20.4.6801; then add an iOS13 device (iPhone_002 is associated with a “wildcard” Provisioning Profile).

Next, I install (didn’t uninstall) v22.1.8625 on top of v20.4.6801; add an iOS 15.1 devices to v22.1.8625. iPhone_005 will continue to associate with the “wildcard” Provisioning Profile earlier:

Though trying to login will failed:

I am happy now, as I can continue to automate those devices. Though not ideal.