Startup Appium error occurred

com.experitest.image.agent.InternalException
at com.experitest.utils.LocalInterProcessLock.tryToReentrivelyExecute(LocalInterProcessLock.java:128)
at imagestudio.ImageStudioApp.main(ImageStudioApp.java:133)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:94)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:25)
Caused by: java.lang.NullPointerException
at com.experitest.licenseutil.CommunitySessionManager$AppPackage.(CommunitySessionManager.java:300)
at com.experitest.licenseutil.CommunitySessionManager.loadAppList(CommunitySessionManager.java:162)
at com.experitest.licenseutil.CommunitySessionManager.(CommunitySessionManager.java:74)
at com.experitest.licenseutil.CommunitySessionManager.getInstance(CommunitySessionManager.java:64)
at com.experitest.licenseutil.CommunityLicenseMgr.init(CommunityLicenseMgr.java:62)
at com.experitest.licenseutil.CommunityLM.initLicense(CommunityLM.java:32)
at com.experitest.Headless.performStaticInitialize(Headless.java:519)
at imagestudio.ImageStudioApp$1.call(ImageStudioApp.java:177)
at imagestudio.ImageStudioApp$1.call(ImageStudioApp.java:133)
at com.experitest.utils.LocalInterProcessLock.tryToReentrivelyExecute(LocalInterProcessLock.java:97)
… 8 more

Please disable the Antivirus in your machine.
Download Appium Studio
Install the Appium Studio again using newly downloaded Appium Studio

hi
thanks
I do that,
but Appium doesn’t work!!!
com.experitest.image.agent.InternalException
at com.experitest.utils.LocalInterProcessLock.tryToReentrivelyExecute(LocalInterProcessLock.java:128)
at imagestudio.ImageStudioApp.main(ImageStudioApp.java:133)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:94)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:25)
Caused by: java.lang.NullPointerException
at com.experitest.licenseutil.CommunitySessionManager$AppPackage.(CommunitySessionManager.java:300)
at com.experitest.licenseutil.CommunitySessionManager.loadAppList(CommunitySessionManager.java:162)
at com.experitest.licenseutil.CommunitySessionManager.(CommunitySessionManager.java:74)
at com.experitest.licenseutil.CommunitySessionManager.getInstance(CommunitySessionManager.java:64)
at com.experitest.licenseutil.CommunityLicenseMgr.init(CommunityLicenseMgr.java:62)
at com.experitest.licenseutil.CommunityLM.initLicense(CommunityLM.java:32)
at com.experitest.Headless.performStaticInitialize(Headless.java:519)
at imagestudio.ImageStudioApp$1.call(ImageStudioApp.java:177)
at imagestudio.ImageStudioApp$1.call(ImageStudioApp.java:133)
at com.experitest.utils.LocalInterProcessLock.tryToReentrivelyExecute(LocalInterProcessLock.java:97)
… 8 more

Sorry, this is a machine-specific problem, we have observed that when some kind of restriction are placed either be an antivirus which restricts jar file download. This problem occurs.

Make sure that you download when antivirus is uninstalled and downloaded the software again and reinstalled the Appium Studio

Please also try if you can ping mhpfsdcush.execute-api.us-east-2.amazonaws.com

If not then try configuring proxy as Appium Studio needs internet to startup and Launch (and connect to mhpfsdcush.execute-api.us-east-2.amazonaws.com).

I set proxy but it does not work again;
I use Appium 2days ago and it work well, but now I can’t work with it .
com.experitest.image.agent.InternalException

Okay . So it was working before well.

So you remember any software which you have installed from 2 days which might have changed your Path variable