iOS Allow notification dialog automatically dismissed after new release 20.4.6801

Before update of Appium studio
I was performing launching iOS .ipa file that was using push notification messaging. Whenever I use Appium studio (whether I use studio for only installing the app manually or run automatic test) System dialog for Allowing notification is shown. This is OK.

After forced update of new Appium studio version to 20.4.6801
The same scenario as above: I install the app with Appium studio, or run automatic test. While launching the app system dialog for allowing notification is shown, and when launching phase is finished, allow notification dialog disappears and I can’t interact with it. So, I can’t allow push notification receiving, and can’t receive push notification because of this.

I use Appium studio version 20.4.6801 on Mac Mojave 10.14.6
The iOS phone I usually use is:
Model name: iPhone 6
Model number: MG472ZD/A
software ver: 12.4.6

How do I know this is the Appium studio problem:
Since I don’t have this problem when I install the app in different way, not using the Appium studio (e.g. via test flight, or when I use devices on Seetest cloud)

I can send you video recordings of what I described above or .ipa file on the email.

Please share the logs (Menu -> Open Logs Folder -> Appium Studio*.log) and video.

I will send you via email.

This is a known issue. Experitest has released a patch, at least for Cloud customers.

We are in progress for getting a cloud license… Sorry, but I don’t fully understand, is there a way to download new Appium studio version with the fix? Thanks :slight_smile:

I don’t know the answer to for Appium Studio. Hopefully someone from Experitest will reply to this thread for you.